BatchPatch Administrator's Guide 2018-08-31

Table of Contents

GETTING STARTED WITH BATCHPATCH ........................................................................................................6
Menu Items ..........................................................................................................................................................6
 FILE .................................................................................................................................................................6
 New tab .........................................................................................................................................................6
 New window ..................................................................................................................................................6
 Open BP Url List... (.bpurl) ..........................................................................................................................7
 Open... ..........................................................................................................................................................7
 Save ..............................................................................................................................................................7
 Save as... ......................................................................................................................................................7
 Save all... ......................................................................................................................................................7
 Password protect .bps/.bpt file contents... .................................................................................................7
 Require / force password protection to be used for all grids... .................................................................7
 Generate template file (.bpt) ......................................................................................................................7
 Generate project file (.bpp) ..........................................................................................................................8
 Export grid .....................................................................................................................................................8
 Export current grid to .html file ...................................................................................................................8
 Export all grids to single .html file ..............................................................................................................8
 Export each grid to separate .html file ........................................................................................................8
 Export host|notes... ......................................................................................................................................8
 Export host#mac|notes... .............................................................................................................................8
 File association (.bps, .bpt, .bpp) ................................................................................................................8
 Exit ..............................................................................................................................................................9
 GRID ..............................................................................................................................................................9
 Add hosts......................................................................................................................................................9
 Add hosts from directory............................................................................................................................10
 Synchronize grid with directory................................................................................................................10
 Row template configurator ........................................................................................................................10
 Row selection color....................................................................................................................................10
 Enable / disable column editing... ............................................................................................................10
 ACTIONS .....................................................................................................................................................11
 View cell contents ....................................................................................................................................11
 Expand / collapse row(s) ........................................................................................................................11
 Remote desktop connection .....................................................................................................................11
 Start pinging .............................................................................................................................................11
 Stop pinging ................................................................................................................................................11
 Ping status alerts ........................................................................................................................................11
 Get information .........................................................................................................................................12
 Get last boot time ......................................................................................................................................12
 Get list of installed programs ...................................................................................................................12
 Get C: disk space ........................................................................................................................................12
 Get logged on users ....................................................................................................................................12
 Get automatic services in stopped state ..................................................................................................12
 Get MAC address ......................................................................................................................................12
Get host name ................................................................. 12
Get CPU usage snapshot .................................................. 12
Get RAM usage snapshot ................................................... 12
Get Windows Update configuration ...................................... 13
Get pending reboot status .................................................. 13
Get registry key/value ....................................................... 13
Get event log entries ........................................................ 13
Create/modify user-defined commands .................................. 14
Execute user-defined commands .......................................... 15

Services / Processes .......................................................... 15
List all services ................................................................... 15
List automatic services ....................................................... 15
List manual services .......................................................... 15
List disabled services ........................................................ 16
List stopped automatic services ......................................... 16
Start stopped automatic services ......................................... 16
Start specific service by name ............................................. 16
Stop specific service by name .............................................. 16
List all running processes .................................................. 16
Check if specific process is running ..................................... 16
Kill specific running process by name .................................. 16
Kill specific running process by PID .................................... 16
Send message to logged-on users .......................................... 17

Reboot .............................................................................. 17
Get pending reboot status .................................................. 17
Get pending reboot status + reboot if required (normal) ........... 17
Get pending reboot status + reboot if required (force) .............. 17
Reboot (normal) ................................................................. 17
Reboot (force, if required) ................................................... 17
Reboot (force always) ........................................................ 18
Reboot (shutdown.exe /r /f /t 0) ............................................. 18
Advanced reboot with user-notification .................................. 18
Abort impending reboot/shutdown countdown ......................... 18
Configure autologon ........................................................... 18
  Insert autologon registry values ......................................... 18
  Remove autologon registry values ....................................... 19

Shutdown ........................................................................ 19
Shutdown (normal) ............................................................. 19
Shutdown (force, if required) ............................................... 19
Shutdown (force always) ...................................................... 19
Shutdown (shutdown.exe /s /f /t 0) ......................................... 19
Advanced shutdown with user-notification .............................. 20
Abort impending reboot/shutdown countdown ......................... 20

Windows Updates .............................................................. 20
Retrieve consolidated url list of available updates ...................... 20
Check for available updates ............................................... 20
Filter which available updates are included or excluded when downloading / installing ........................................... 21
  Include / exclude specific updates (graphical) ....................... 21
  Include specific updates (textual) ......................................... 21
Download offline updates repository
Export saved commands, deployments, job queues
Import saved commands, deployments, job queues
Run BatchPatch as a service
Settings

General Settings
- Grid export directory for job queue and scheduler
- Low C: Disk Space Warning Threshold
- Concurrent Thread Maximum (0 == unlimited)
- Concurrent File-Copy Operations Maximum (for Deployment Action)
- Remote Desktop Connection Port
- Default Open for .bps/bpt file password security – PBKDF2 iterations
- Use system default log file viewer instead of BatchPatch built-in viewer
- Force pinger to always use IPv4 addresses
- Global exclusions list for automatic services in stopped state
- Automatically start host status check (LED colors) on startup/new tab/open
- Enable Task Scheduler on startup

Remote Execution Context
- Show 'Getting Started' window at startup
- Check for updates on startup
- Remember open tabs from last session when launching BatchPatch.exe
- Remember open tabs from last session when launching .bps, .bpt, or .bpp
- Minimize button: Left click min to taskbar / right click min to tray
- Minimize button: Left click min to tray / right click min to taskbar

Grid Preferences
- Hosts are considered offline after X ping timeouts
- Automatically stop pinging when host comes online after having been offline
- Enable row sorting
- Show tab header alert images
- Hide 'View cell contents' right-click context menu-item
- Show ping status alerts image column when adding hosts to new grid
- Prevent duplicate host names from being added to grid
- Use custom timestamp in 'All Messages' column
- Allow BatchPatch to auto-resize column widths to a max of
- Allow BatchPatch to auto-resize the window width to a max of
- Allow BatchPatch to unhide columns automatically
- Reset columns on startup and on new tab creation
- Reset window size on launch (applies only to tab mode)
- Auto-resize settings for 'View cell contents' (middle-click) tooltip

Windows Update Agent Settings
- Search Preferences
- Server Selection
- Update Classification Filtering
- Update Date Filtering (skip download / installation of recently deployed updates)
- EULA behavior
- Cached mode and offline mode

Remote Execution
- Remote Working Directory
- Use PsExec – r switch to specify remote service name
- Remote Execution Context
Email Notifications Settings
From (email address)
Recipients (comma separated or one email address per line):
SMTP Server:
Port:
Unauthenticated / Specify SMTP logon credentials
Body format
Subject
Body
Include HTML Attachment
Send test email

Ping Status Alerts Settings
Global default alert settings for NEW rows:
Alert sounds for ALL rows
Hosts are considered offline after X ping timeouts
Automatically stop pinging when host comes online after having been offline
Show ping status alerts image column when adding hosts to new grid
Run as service settings
Audit Logging Settings

VIEW
Multi-grid mode
Toggle multi-grid layout

Other
General Tips
Host Status “LED” Color Indicators
Keyboard Shortcuts
Tutorials

GETTING STARTED WITH BATCHPATCH
If this is your first time using BatchPatch, please start by reading through the Getting Started page at http://batchpatch.com/getting-started-with-batchpatch to learn how to configure your environment to work smoothly with BatchPatch

Menu Items

FILE

New tab
Use the 'New tab' item to create a new, empty grid in BatchPatch. Note, you can drag and drop tabs between instances of BatchPatch if they have been saved to .bps format with File>Save. If you attempt to drag a tab while actions are executing on it, you will be prompted to save the tab, the actions will be orphaned, and then the tab will be moved to the new or other BatchPatch instance.

New window
Use the 'New window' item to launch a new instance of BatchPatch.exe. Note, you can drag and drop tabs between instances of BatchPatch if they have been saved to .bps format with File>Save. If you attempt to drag a tab while actions are executing on it, you will be prompted to save the tab, the actions
will be orphaned, and then the tab will be moved to the new or other BatchPatch instance.

**Open BP Url List... (.bpurl)**

This option is used for 'cached mode' and 'offline mode.' It enables you to open a previously created *.bpurl list so that you may use BatchPatch to download all of the files in the list. To create a *.bpurl list, use Actions > Windows Updates > Retrieve Consolidated Url List of Available Updates

**Open...**

You can use the 'Open' option to load .txt, .bps, .bpt, and .bpp files.

**Save**

Save the currently active grid. If the grid has not been previously saved, you will be prompted to choose a filename and location to save it to.

**Save as...**

Save the currently active grid with a new name. Even if the grid has been previously saved, you can use the 'Save as' item to save it as a different filename.

**Save all...**

Save all tabs / grids open in BatchPatch. If a grid has not been previously saved, you will be prompted to choose a filename and location to save it to.

**Password protect .bps/.bpt file contents...**

Use this dialog to set a password, which will be used by BatchPatch to derive a key to perform 256-bit AES encryption when saving this grid to a .bps/.bpt file.

To maximize security we recommend an absolute minimum of 12 characters (longer is better!), with a mix of uppercase letters, lowercase letters, numbers, and non-alphanumeric characters. A long, non-dictionary, high-entropy password is of paramount importance to prevent a brute-force attack from being successful.

To further increase security and make a brute-force attack even more difficult, you may modify/increase the number of iterations used during key derivation (PBKDF2) under 'Tools > Settings > PBKDF2 iterations'

**Require / force password protection to be used for all grids**

When this setting is enabled, each time you attempt to save a grid BatchPatch will prompt you to enable password protection for that grid before it will allow you to save it. You can use this setting to make sure you remember to set password protection on new grids, so that you don't accidentally save a grid without first protecting it.

**Generate template file (.bpt)**

A BatchPatch template file (.bpt) is simply a BatchPatch state file (.bps) that has been named with a
.bpt extension instead of .bps. When you load a .bpt file into BatchPatch, BatchPatch will not allow you to save over it. When you try to save it, you will instead be forced to “Save As” a .bps file.

The Generate template file option will enable you to create a .bpt file from any grid in BatchPatch. However, you may also create your own .bpt files by simply renaming existing .bps files with the .bpt extension.

Generate project file (.bpp)

A BatchPatch project file (.bpp) is actually just a regular text file with a .bpp extension that contains a list of full filepaths to .bps files. If you load a .bpp file into BatchPatch, all the .bps files listed in the .bpp file will be loaded as separate tabs.

When you generate a .bpp file using the File > Generate project file option, BatchPatch will create a .bpp file that contains the saved filepath of each open tab in that instance of BatchPatch. If a tab has never been saved to a .bps file, it will not be included in the .bpp file.

Export grid

Export current grid to .html file

This option will export the active tab's grid to an HTML file.

Export all grids to single .html file

This option will export all the open tabs in BatchPatch to a single, combined HTML file.

Export each grid to separate .html file

This option will export each open tab's grid to its own HTML file

Export host|notes...

This option enables you to take an active grid and export just the Host and Notes columns. The format is pipe (|) delimited. Sometimes it's convenient to maintain .txt file lists of hosts and notes. You can then later load the .txt file with the notes included simply by dragging it onto BatchPatch. Or alternatively, if you have a grid that already contains a list of hosts but doesn't contain any notes, you can import just the notes portion of one of these host|notes export files using Actions>Import notes or MACs addresses.

Export host#mac|notes...

This option enables you to take an active grid and export just the Host, Mac Address, and Notes columns. Sometimes it's convenient to maintain .txt file lists of hosts and notes. You can then later load the .txt file with the mac addresses and notes included for each host simply by dragging it onto BatchPatch.

File association (.bps, .bpt, .bpp)

You can register and unregister the .bps, .bpt, and .bpp extensions with your system. Since BatchPatch is effectively a “portable” application, there is no installation. If you save a grid with File>Save, the file extension that BatchPatch uses is .bps. If you want to be able to double-click on a .bps file and have it automatically launch in BatchPatch, you need to first register the .bps extension with your system. Note, the registration is tied to the location of the BatchPatch.exe that is currently running. If
you have BatchPatch running from your desktop when you choose the option File>File association (.bps)>Register .bps extension, the next time you double-click a .bps file, it will launch BatchPatch from the desktop location where the executable is saved, automatically loading the .bps file that you double-clicked. If you later move the executable to a new location, such as C:\Program Files\BatchPatch, you will need to re-register that new location. Registration and de-registration may require a reboot in order to see the BatchPatch icon overlay appear on or disappear from .bps files.

.bpt files are identical to .bps files. If you rename a .bps file to .bpt (BatchPatch Template), when you launch the .bpt file, it will not allow you to save over it. Instead you will be forced to Save As to a .bps file. This way you can have a set of .bpt template files that you use over and over without ever overwriting them.

.bpp files are simple text files that can be used to launch multiple .bps or .bpt files simultaneously. The format of a .bpp file is simple. Create a text file that contains one full filepath per line, where each filepath is the location of a .bps or .bpt file. When you launch a .bpp file, each .bps or .bpt file that is specified inside the .bpp file will be opened in BatchPatch.

For example, you might have a 4-line .bpt file with contents that look like this:

C:\myBpsFiles\computerList1.bps
C:\myBpsFiles\computerList2.bps
C:\myBptFiles\templateList1.bps
C:\myBptFiles\templateList2.bps

As long as the file is saved with a .bpp extension (instead of .txt), BatchPatch will treat it as a BatchPatch Project file. Any time you launch a .bpp file, all filepaths in the .bpp file will be launched in the same BatchPatch instance.

**Exit**

Use the File>Exit option to close the application. You will be prompted to save any unsaved grids.

**GRID**

**Add hosts...**

BatchPatch allows you to add hosts by entering a list of names into the 'Add hosts' dialog or by saving a list of names into a .txt file and then dragging that .txt file onto the BatchPatch grid.

When importing hosts, you can also import other information such as MAC address by using # as delimiter, or Notes by using the | (pipe) symbol. The following are all valid and can be entered into the 'Add Hosts' dialog or put in a text file:

The order of values entered must be the same as the order shown below:

```
# MAC   | NOTES   | NOTES2 | DESCRIPTION | LOCATION | USERNAME | PASSWORD | DOMAIN
```

Syntax examples for adding hosts with extra values: (Note it is not necessary to include all elements as long as the overall order of elements is retained)

```
host1#1C6F65D56413
host2#1B3A65B54322|notes for host2
```
Add hosts from directory...

BatchPatch allows you to add hosts that are selected directly from your Active Directory. When you launch the 'Add hosts from directory' dialog, BatchPatch tries to determine the default naming context for your domain. If BatchPatch is unable to determine this, you must manually enter the domain controller that you want BatchPatch to look at for directory information. This is a standard LDAP query, so you would enter into the LDAP:// field one of the following:

- DomainControllerName
- DC=DomainName,DC=com
- DomainControllerName/DC=DomainName,DC=com

Once you have established a connection and displayed the directory tree, you simply select the OU that contains the hosts you want to add. If you tick the 'Recursive Search' box, selecting a given OU will not only display the hosts in that OU but will also display hosts in all sub OUs. Highlight the computers you want to add to the grid, click the right-arrow button to move them to the 'Add to grid' list, and then click OK.

Synchronize grid with directory...

Use this feature to “link” a BatchPatch grid to a list of OUs and/or security groups in Active Directory. You can then synchronize the grid so that it contains the computers in the specified OUs and groups. This makes it much easier to keep your grids up to date with the new computers in your organization.

Row template configurator

Use this form to create or modify a BatchPatch grid's row template. Each grid can have its own row template. When enabled, a host that is added to the grid will automatically receive the row template cell contents. This is helpful if you want to automatically apply a scheduled task or job queue to new hosts that are added to the grid.

Highlight a single row in the main BatchPatch grid, and then click the 'Create/update...' button to set the row template based on the highlighted row. Any scheduled task, deployment, job queue, remote command, local command etc that exist in the highlighted row will become a part of the template. Then any time when a new row is added to the grid, any cells that exist in the row template will be copied to the new row that is added.

Row selection color...

Change the row selection color to one of the factory colors or to a custom color of your choice. To create a custom row color, simply click on the color palette icon.

Enable / disable column editing...

Sometimes it's convenient to be able to modify specific columns directly, while other times you might prefer to not be able click into a column to edit it directly. Use this dialog window to control which
columns are editable.

**ACTIONS**

**View cell contents**

We strongly encourage you to get used to viewing the cell contents by clicking the middle mouse button or scroll-wheel button over a particular cell. You can then even hide the 'View cell contents' menu item, to save space, by going to Tools > Settings > Hide 'View cell contents' right-click context menu item.

The tooltip window that is displayed when you middle-click on a cell is resizable, scrollable, and movable. To move it to a new location, press the CTRL key while you left-click anywhere on the tooltip window. You will then be able to drag it around the screen to a new location.

**Expand / collapse row(s)**

This option gives you another way to view the contents of a cell inside the grid. The row will be auto-sized to fit the entire contents of the cells in that row. We typically consider this option inferior to the middle-click option, which reveals the 'View cell contents' tooltip. However, there are times when this expand/collapse option might be preferable.

**Remote desktop connection**

A remote desktop connection will automatically be launched for the selected hosts in the grid. If you use a non-default RDP port in your environment, you can change this value in Tools > Settings > Remote Desktop Connection Port. The default RDP port in Windows is 3389.

**Start pinging**

Start pinging the selected rows. Note that if you do not choose to ping a particular host, but you then later initiate a Windows update action or a reboot, BatchPatch will automatically start pinging the host when the reboot is initiated.

**Stop pinging**

Stop pinging the selected hosts.

**Ping status alerts**

You can configure BatchPatch to produce audible alerts or email alerts when hosts go offline or come online while BatchPatch is pinging them.

The ping status alert default settings are configurable under Tools > Settings > Ping Status Alerts. You are able to select your own .wav files or simply use the built-in BatchPatch sounds. If you choose to enable email alerts in addition to or instead of audible alerts, the email alerts will be sent from and to the addresses that are specified in Tools > Settings > Email Notifications. However, you may also choose to override any particular row's recipients list, in which case alerts for that particular row will be sent only to the override list. To override an email recipient list for a given row, highlight the row and select Actions > Email notification > Override default email notification settings.

Middle-clicking on a row's ping status image column icon will launch the Ping Status Alerts configuration window. This is the same as clicking Actions > Ping status alerts.
Shift-middle-clicking on a row's ping status image column icon will toggle it.

**Get information**

**Get last boot time**
Retrieve the last bootup time value from the selected hosts

**Get list of installed programs**
Uses 'WMIC PRODUCT GET Caption' to retrieve the list of installed programs, as recorded by the Windows Installer on target computers

**Get C: disk space**
Retrieve the used/total space on the C drive of the target hosts. If you want to view other drives' available space, you can create a custom query in the 'Create/modify user defined commands.' For example, you can retrieve the breakdown for all disks on a target computer with the following command:

WMIC PATH Win32_LogicalDisk where "drivetype=3" GET deviceid, volumename, freespace, size

**Get logged on users**
List the logged on users for the selected hosts

**Get automatic services in stopped state**
Retrieve a list of services that are set to automatic but in a stopped state on the selected hosts. You can exclude specific services from the check by adding service display names to the exceptions list under 'Tools > Settings > General.' Note, the 'Services / Processes' action has more pre-coded actions available, such as starting all the stopped automatic services.

**Get MAC address**
Retrieve the MAC address for the selected hosts. Without the MAC address field populated for a given row, the Wake On LAN action will not work. The following formats are all supported:

1D-6E-65-F5-64-13
1D:6E:65:F5:64:13
1D6E65F56413

**Get host name**
Retrieve the host name from the selected hosts. This is particularly convenient to verify that DNS is correct for a given host name since this method will actually ask the host what its name is, rather than relying on DNS to give an accurate answer. This method is also convenient to convert a list of IP addresses to host names without relying on DNS.

**Get CPU usage snapshot**
Displays the CPU usage percentage on the selected host

**Get RAM usage snapshot**
Displays the CPU usage on the selected host
**Get Windows Update configuration**

Displays the WSUS server that the selected hosts are configured to use. Typically most organizations use Group Policy to control which WSUS server its computers point to. When Group Policy has been used to set this value, the following registry key is created:

HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate\WUServer

BatchPatch attempts to read this registry value. If it doesn't exist, then the host has not been configured to use a WSUS server and will instead still use Microsoft Update.

**Get pending reboot status**

Displays TRUE if the selected host is pending reboot, or FALSE if there is no pending reboot.

Windows does not have a single location to check for whether or not a computer is pending reboot. BatchPatch checks the following locations on selected hosts to determine if reboot is pending:

- HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update: If a subkey contains “RebootRequired” BatchPatch returns TRUE.
- HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing: If a subkey contains “RebootPending” BatchPatch returns TRUE.
- HKLM\SOFTWARE\Microsoft\Updates: If the UpdateExeVolatile value exists and is greater than 0, BatchPatch returns TRUE.
- CCM_ClientUtilities.DetermineIfRebootPending method: If the host has SCCM 2012 installed and this method returns TRUE, BatchPatch returns TRUE.
- HKLM\SYSTEM\CurrentControlSet\Control\Session Manager: If the PendingFileRenameOperations value contains any filepaths, BatchPatch displays them.

**Get registry key/value**

Use this feature to view the contents of a registry key on target computers.

The registry key field must contain the full path to a valid subkey and must include a valid root key. Valid root keys are: HKLM and HKU.

For example:

Registry key: HKLM\Software\Microsoft\.NETFramework

Value name: InstallRoot

The value name field is optional. If specified, BatchPatch will retrieve only the data of value you specify. If left empty, BatchPatch will retrieve the list of all subkeys and values in the specified registry key.

**Get event log entries**

This feature enables you to retrieve event log entries from target computers. Note that in order for this to work, not only will you need an account that has local administrator permission on the targets but you will also need to make sure that the Remote Registry service is enabled and started on the target
hosts.

**Create/modify user-defined commands**

You can create your own commands to retrieve information from remote hosts. The commands that you create will then appear hard-coded into the 'Execute user-defined commands' sub-menu. You'll notice that BatchPatch has multiple 'user-defined commands.' There is one under 'Get information' as well as one under 'Remote process/command.' The only difference between these two is that when you execute user-defined commands under 'Remote process/command,' you will be prompted to confirm the action before it is executed. The 'Get information' user-defined commands will NOT prompt for confirmation. The idea here is that under 'Get information' you'd store the commands that you use to read information from the target computers. Then in the 'Remote process/command' area you'd store the commands that will actually execute methods on the target computers. This concept is not enforced, of course. It's just a suggested way to use BatchPatch. Ultimately, you decide which commands you want stored in which locations.

You can execute commands here as if you were at the console or command prompt of a remote computer. Here are just some examples of the types of commands you can execute:

**List all services:** WMIC SERVICE list brief

**Start the DNS Client service:** WMIC SERVICE where caption='DNS Client' CALL startservice

**Stop the DNS Client service:** WMIC SERVICE where caption='DNS Client' CALL stopservice

**List all running processes:** WMIC SERVICE where state='running' GET name, displayname, pathname, processID

**List all stopped automatic services:** WMIC SERVICE where (state='stopped' and startmode='auto') GET displayname, name

**Start all stopped automatic services:** WMIC SERVICE where (state='stopped' and startmode='auto') CALL startservice

**Set the DNS Client to manual:** WMIC SERVICE where (DisplayName='DNS Client') CALL ChangeStartMode Manual

**List all processes:** WMIC PROCESS list brief

**Terminate specific process:** WMIC PROCESS where name='hungProcess.exe' call terminate

**Delete specific process:** WMIC PROCESS where name='hungProcess.exe' delete

**List all user accounts:** WMIC USERACCOUNT list brief
Get CPU info: WMIC CPU get name, caption, maxclockspeed, systemname
Get OSVersion: WMIC OS GET caption, servicepackmajorversion, version

Get model: WMIC PATH Win32_ComputerSystem GET model

Get BIOS info: WMIC PATH Win32_BIOS GET caption

Get system type: WMIC PATH Win32_ComputerSystem GET systemtype

List OCZ brand disk drives in system: WMIC PATH Win32_DiskDrive where "model like '%OCZ %'" GET deviceID, model

List non-OCZ brand disk drives in system: WMIC PATH Win32_DiskDrive where "not model like '%OCZ%'" GET deviceID, model

List fixed disks: WMIC PATH Win32_LogicalDisk where "drivetype=3" GET deviceid, volumename, freespace, size

Retrieve output of TASKLIST command: TASKLIST

Execute the TASKKILL command: TASKKILL /F /IM "hungProcess.exe"

Execute the PATHPING command: PATHPING google.com

Execute user-defined commands
Once you have created at least one command under 'Create/modify user-defined commands,' your commands will appear hard-coded in the sub-menu under 'Execute user-defined commands.'

Services / Processes

List all services
This hard-coded action retrieves a list of all services on a target computer by executing the following command: WMIC SERVICE list brief

List automatic services
This hard-coded action retrieves a list of all services that are set to 'automatic' by executing the following command: WMIC SERVICE where (startmode='auto') GET displayname, name

List manual services
This hard-coded action retrieves a list of all services that are set to 'manual' by executing the following command: WMIC SERVICE where (startmode='manual') GET displayname, name
**List disabled services**

This hard-coded action retrieves a list of all services that are set to 'disabled' by executing the following command: WMIC SERVICE where (startmode='disabled') GET displayname, name

**List stopped automatic services**

This hard-coded action retrieves a list of all services that are set to 'automatic' and in a stopped state. You can exclude specific services from the check by adding service display names to the exceptions list under 'Tools > Settings > General.'

**Start stopped automatic services**

This hard-coded action starts all automatic services that are in a stopped state by executing the following command: WMIC SERVICE where (state='stopped' AND startmode='auto') CALL startservice

**Start specific service by name...**

The action allows you to start a specific service on target computers by entering the display name for that service. The display name is what you see in the “Name” column when you launch the Windows services console (Start > Run > Services.msc).

**Stop specific service by name...**

The action allows you to stop a specific service on target computers by entering the display name for that service. The display name is what you see in the “Name” column when you launch the Windows services console (Start > Run > Services.msc).

**List all running processes**

This hard-coded action lists all running processes on the target computers by executing the following command: WMIC PROCESS list brief

**Check if specific process is running...**

Enter the name of a process (or multiple process names separated by commas) to check if it is currently running on the target host. e.g. “notepad.exe”

**Kill specific running process by name...**

The action allows you to terminate a specific process on target computers by entering the name of that process. The following command is executed: WMIC PROCESS where name='ProcessName.exe' call terminate

**Kill specific running process by PID...**

The action allows you to terminate a specific process on target computers by entering the PID of that process. The following command is executed: WMIC PROCESS where processID='1234567' call terminate
Send message to logged-on users

You can use this feature to create a pop-up notification on the target computers that contains a custom message. Optionally set a time limit, in seconds, before the message automatically closes. If a time limit is not specified, the message will stay there until the user acknowledges it.

Reboot

**Get pending reboot status**

Displays TRUE if the selected host is pending reboot, or FALSE if there is no pending reboot.

Windows does not have a single location to check for whether or not a computer is pending reboot. BatchPatch checks the following locations on selected hosts to determine if reboot is pending:

- HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update: If a subkey contains “RebootRequired” BatchPatch returns TRUE.
- HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing: If a subkey contains “RebootPending” BatchPatch returns TRUE.
- HKLM\SOFTWARE\Microsoft\Updates: If the UpdateExeVolatile value exists and is greater than 0, BatchPatch returns TRUE.
- CCM_ClientUtilities.DetermineIfRebootPending method: If the host has SCCM 2012 installed and this method returns TRUE, BatchPatch returns TRUE.
- HKLM\SYSTEM\CurrentControlSet\Control\Session Manager: If the PendingFileRenameOperations value contains any filepaths, BatchPatch displays them.

**Get pending reboot status + reboot if required (normal)**

Check if a reboot is pending. If yes, then initiate a normal reboot. A normal reboot typically will not succeed if a user is a logged on to the computer.

**Get pending reboot status + reboot if required (force)**

Check if a reboot is pending. If yes, then initiate a normal reboot. A normal reboot typically will not succeed if a user is a logged on to the computer. If the normal reboot fails, a force reboot will be initiated.

**Reboot (normal)**

Reboot is initiated on the target computers via remote Windows Management Instrumentation (WMI). A normal reboot does not attempt to force applications to close or to logoff any user sessions, which means that depending on what is active on the target computers a reboot may or may not occur.

All reboot and shutdown operations will automatically start pinging the target computer(s), so there is no need to manual start pinging before executing one of these methods.

**Reboot (force, if required)**

This is the recommended way to initiate reboots on target computers. BatchPatch will first attempt a
normal reboot. If the normal reboot is not able to complete for any reason, BatchPatch will immediately attempt a force reboot.

All Windows Updates actions that initiate reboots automatically, such as “Download and install updates + reboot if required,” always use the “Reboot (force, if required) method.”

All reboot and shutdown operations will automatically start pinging the target computer(s), so there is no need to manual start pinging before executing one of these methods.

**Reboot (force always)**

Reboot is initiated on the target computers via remote Windows Management Instrumentation (WMI). A force reboot not only attempts to kill any active user sessions but also forcibly closes any running programs. This means unsaved work could be lost when using a force reboot. Also, due to the nature of how the force method works, sometimes when BatchPatch initiates a force reboot, the target computer isn't able to report success back to BatchPatch before the target begins its shutdown sequence. In certain cases BatchPatch might display an error despite the target computer rebooting successfully. This is expected / normal.

All reboot and shutdown operations will automatically start pinging the target computer(s), so there is no need to manual start pinging before executing one of these methods.

**Reboot (shutdown.exe /r /f /t 0)**

For the sake of flexibility, we provide an alternate method to initiate reboot that does not rely on Windows Management Instrumentation (WMI). Instead, BatchPatch sends a “shutdown.exe /r /f /t 0” command to the target computers via PsExec. Generally speaking there isn't a need to use this method over the normal reboot methods. However, if WMI has not been properly allowed in network firewalls, this alternate method is a second option.

All reboot and shutdown operations will automatically start pinging the target computer(s), so there is no need to manual start pinging before executing one of these methods.

**Advanced reboot with user-notification**

This option emulates “shutdown.exe /i” to give you the option of notifying logged on users of the impending reboot, with a countdown. It also enables you to log a reason code to the event log of the target computer.

**Abort impending reboot/shutdown countdown**

If you previously executed an advanced reboot/shutdown with countdown timer (see Advanced reboot with user-notification), and now the target computers are going to reboot/shutdown at the end of the countdown, you can abort the impending reboot/shutdown with this action.

**Configure autologon**

**Insert autologon registry values**

Windows can be configured to automatically logon after reboot by inserting registry values that contain the username and password for the user that is to be logged on automatically. BatchPatch can do this for you, but please be aware that the values are stored in plain text in the target computer's registry, which makes this practice potentially insecure. Use the 'Remove autologon registry values' action after the reboot is complete to clear the previously inserted entries.
Registry values are inserted into the following key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

More info: https://support.microsoft.com/kb/324737

Remove autologon registry values
Use the 'Remove autologon registry values' to clear previously inserted username/password autologon entries.

Shutdown

Shutdown (normal)
Shutdown is initiated on the target computers via remote Windows Management Instrumentation (WMI). A normal shutdown does not attempt to force applications to close or to logoff any user sessions, which means that depending on what is active on the target computers a shutdown may or may not occur.

All reboot and shutdown operations will automatically start pinging the target computer(s), so there is no need to manual start pinging before executing one of these methods.

Shutdown (force, if required)
This is the recommended way to initiate shutdowns on target computers. BatchPatch will first attempt a normal shutdown. If the normal shutdown is not able to complete for any reason, BatchPatch will immediately attempt a force shutdown.

All Windows Updates actions that initiate shutdowns automatically, such as “Download and install updates + shutdown,” always use the “Shutdown (force, if required) method.”

All reboot and shutdown operations will automatically start pinging the target computer(s), so there is no need to manual start pinging before executing one of these methods.

Shutdown (force always)
Shutdown is initiated on the target computers via remote Windows Management Instrumentation (WMI). A force shutdown not only attempts to kill any active user sessions but also forcibly closes any running programs. This means unsaved work could be lost when using a force shutdown. Also, due to the nature of how the force method works, sometimes when BatchPatch initiates a force shutdown, the target computer isn't able to report success back to BatchPatch before the target begins its shutdown sequence. In certain cases BatchPatch might display an error despite the target computer shutting down successfully. This is expected / normal.

All reboot and shutdown operations will automatically start pinging the target computer(s), so there is no need to manual start pinging before executing one of these methods.

Shutdown (shutdown.exe /s /f /t 0)
For the sake of flexibility, we provide an alternate method to initiate shutdown that does not rely on Windows Management Instrumentation (WMI). Instead, BatchPatch sends a “shutdown.exe /s /f /t 0” command to the target computers via PsExec. Generally speaking there isn't a need to use this method over the normal shutdown methods. However, if WMI has not been properly allowed in network firewalls, this alternate method is a second option.
All reboot and shutdown operations will automatically start pinging the target computer(s), so there is no need to manually start pinging before executing one of these methods.

**Advanced shutdown with user-notification**

This option emulates “shutdown.exe /i” to give you the option of notifying logged on users of the impending shutdown, with a countdown. It also enables you to log a reason code to the event log of the target computer.

**Abort impending reboot/shutdown countdown**

If you previously executed an advanced reboot/shutdown with countdown timer (see Advanced shutdown with user-notification), and now the target computers are going to reboot/shutdown at the end of the countdown, you can abort the impending reboot/shutdown with this action.

**Windows Updates**

The Windows Updates actions enable you to control the Windows Update agent on target computers to check for available updates, download updates, and install updates. BatchPatch provides some user configurable settings for the Windows Update actions, which can be modified under Tools > Settings > Remote Agent Settings.

The update server that BatchPatch uses (your own WSUS server or Microsoft's Update server) to download updates is whatever server your target computers are configured to use. Most organizations use Group Policy to control which update server their computers connect to. If Group Policy has not been used, and if a target computer has not been individually set to use a specific WSUS server, then that target computer will use the default Microsoft Update server.

When you utilize BatchPatch to initiate a Windows Update action, BatchPatch tells the target computer what to do, and then the target computer itself does the actual check/download/installation of updates from the update server that it is configured to use, or from Microsoft Update, if the target computer has not been configured to use a local WSUS server.

**Retrieve consolidated url list of available updates**

To use this option you must first enable 'cached mode' or 'offline mode' in Tools > Settings > Windows Update. This action will check for available updates on target hosts and then retrieve the list with a download link for each update. See Cached Mode and Offline Updates for more information.

**Check for available updates**

BatchPatch will initiate an online scan against the configured WSUS server (or Microsoft's Update server, if the target has not been configured to use a local WSUS) to see what updates are available for the target. A log of available updates is saved on each target to the BatchPatch.log file in the remote working directory. The remote working directory default location is C:\Program Files\BatchPatch on all targets, but this is configurable under Tools > Settings.

You can view the a target computer's BatchPatch.log file directly from BatchPatch by selecting Actions > Windows Updates > View BatchPatch.log.

In addition to logging available updates in the BatchPatch.log file on each target, the BatchPatch console also captures this log in the “Remote Agent Log” column. This column is automatically displayed during a check for available updates. However, because this column can contain a lot of data, you may notice that closing/hiding this column improves the responsiveness of BatchPatch.
During a download/installation of updates, this column is NOT automatically displayed (unless it is already open/unhidden), but it is still updated upon completion of the Windows Update action for any given target host.

**Filter which available updates are included or excluded when downloading / installing**

**Include / exclude specific updates (graphical)**

In this interface check the box next to each update that you want to include in download/install operations. Uncheck the box next to each update that you want to exclude from download/install operations. After checking/unchecking all desired boxes, click 'Apply' or 'OK' to apply those inclusions/exclusions to each row in the source BatchPatch grid. Once applied to the row(s), any subsequent Windows Update download or install action that is executed on that row will utilize the applied filter until the filter is cleared.

**Include specific updates (textual)**

Use this list to specify which updates are downloaded and/or installed when you initiate a Windows Update action in BatchPatch. Note, this list can only be used to download/install updates that are already available to a given target machine. This is to say that if you put a KB number into this list but that KB number is not being offered by your update server, it will not be installed. So, in order to effectively use this list, you should first use Actions > Windows Update > Check for available updates in BatchPatch to view the list of updates that are available to the machine. Then you may pick specific updates from the list of available updates to create a list of specific updates for download/installation.

If this list is empty, BatchPatch will download and/or install any/all available updates, applying only the filters that are configured under Tools > Settings > Remote Agent Settings.

If this list is populated, BatchPatch will download and/or install only updates that are in the list, after first applying the filters that are configured under Tools > Settings > Remote Agent Settings. However, as noted above, the updates in this list must be available to the target computer. If the target computer's update server is not offering an update that you add to the list, it will not be installed.

Matching is done by comparing the update title to the text of each item in the list. If the text of any item in the list below is contained in the update title, the update will be downloaded and/or installed. To guarantee uniqueness, we recommend entering the KB IDs of the updates that you would like to download / install, though you may provide a different search string if you prefer. For example:

KB123456
KB234567
KB345678

**Exclude specific updates (textual)**

Use this list to specify which updates are excluded when you initiate a download or installation Windows Update action in BatchPatch.

If this list is empty, BatchPatch will download and/or install any/all available updates, applying only the filters that are configured under Tools > Settings > Remote Agent Settings.

If this list is populated, BatchPatch will download and/or install only updates that are available to the machine but do NOT appear in the list, after first applying the filters that are configured under Tools > Settings > Remote Agent Settings.

Matching is done by comparing the update title to the text of each item in the list. If the text of any
item in the list below is contained in the update title, the update will be downloaded and/or installed. To guarantee uniqueness, we recommend entering the KB IDs of the updates that you would like to download / install, though you may provide a different search string if you prefer. For example:

KB123456
KB234567
KB345678

**Clear filter list**

Use this menu item to clear the filter list that you created using the 'Include / exclude specific updates' noted above.

**Download available updates**

BatchPatch will initiate a download of available updates.

A log of downloaded updates is saved on each target to the BatchPatch.log file in the remote working directory. The remote working directory default location is C:\Program Files\BatchPatch on all targets, but this is configurable under **Tools > Settings**.

You can view the a target computer's BatchPatch.log file directly from BatchPatch by selecting **Actions > Windows Updates > View BatchPatch.log**.

In addition to logging downloaded updates in the BatchPatch.log file on each target, the BatchPatch console also captures this log in the “Remote Agent Log” column. This column is automatically displayed during a check for available updates. However, because this column can contain a lot of data, you may notice that closing/hiding this column improves the responsiveness of BatchPatch.

During a download/installation of updates, this column is NOT automatically displayed (unless it is already open/unhidden), but it is still updated upon completion of the Windows Update action for any given target host.

**Download and install updates**

BatchPatch will initiate a download of available updates. Once the download is complete, all updates will be installed on the target.

A log of downloaded and installed updates is saved on each target to the BatchPatch.log file in the remote working directory. The remote working directory default location is C:\Program Files\BatchPatch on all targets, but this is configurable under **Tools > Settings**.

You can view the a target computer's BatchPatch.log file directly from BatchPatch by selecting **Actions > Windows Updates > View BatchPatch.log**.

In addition to logging downloaded and installed updates in the BatchPatch.log file on each target, the BatchPatch console also captures this log in the “Remote Agent Log” column. This column is automatically displayed during a check for available updates. However, because this column can contain a lot of data, you may notice that closing/hiding this column improves the responsiveness of BatchPatch. During a download/installation of updates, this column is NOT automatically displayed (unless it is already open/unhidden), but it is still updated upon completion of the Windows Update action for any given target host.
**Download and install updates + reboot if required**

BatchPatch will initiate a download of available updates. Once the download is complete, all updates will be installed on the target. If the target host requires a reboot to complete the installation of updates, BatchPatch will automatically start pinging it and initiate a reboot.

**Download and install updates + reboot always**

BatchPatch will initiate a download of available updates. Once the download is complete, all updates will be installed on the target. Regardless of whether or not the target host requires a reboot to complete the installation of updates, BatchPatch will automatically start pinging it and initiate a reboot.

**Install downloaded updates**

BatchPatch will initiate an offline scan to see what updates have already been downloaded on the target(s). The update server does not need to be online in order for this action to take place. In fact, this action does not cause the target(s) to communicate with the update server at all. Updates that have already been downloaded will then be installed.

**Install downloaded updates + reboot if required**

BatchPatch will initiate an offline scan to see what updates have already been downloaded on the target(s). The update server does not need to be online in order for this action to take place. In fact, this action does not cause the target(s) to communicate with the update server at all. Updates that have already been downloaded will then be installed. If the target host requires a reboot to complete the installation of updates, BatchPatch will automatically start pinging it and initiate a reboot.

**Install downloaded updates + reboot always**

BatchPatch will initiate an offline scan to see what updates have already been downloaded on the target(s). The update server does not need to be online in order for this action to take place. In fact, this action does not cause the target(s) to communicate with the update server at all. Updates that have already been downloaded will then be installed. Regardless of whether or not the target host requires a reboot to complete the installation of updates, BatchPatch will automatically start pinging it and initiate a reboot.

**Update + reboot cycle**

The update/reboot cycle enables you to create a custom set of actions to execute on target machines, all with just a single click. Perhaps you want to download and install updates, then reboot, then download and install updates once again and reboot again. You can do this very easily with the update/reboot cycle option. Note that there is only a single, global cycle. If you need to have a different cycle for each row, use the Job Queue instead.

**Modify default cycle settings**

You may create your own custom cycle simply by choosing which actions you want to execute. Put them in the order you want them to be executed, and then click OK to save the cycle. To initiate the cycle, click on the “Execute cycle” menu item.
Execute cycle
Executes the update/reboot cycle specified in the “Modify default cycle settings” Window.

Update + shutdown

Install downloaded updates + shutdown
BatchPatch will initiate an offline scan to see what updates have already been downloaded on the target(s). The update server does not need to be online in order for this action to take place. In fact, this action does not cause the target(s) to communicate with the update server at all. Updates that have already been downloaded will then be installed. When installation is finished, BatchPatch will start pinging and send a shutdown command to the target(s).

Download and install updates + shutdown
BatchPatch will initiate a download of available updates. Once the download is complete, all updates will be installed on the target. When installation is finished, BatchPatch will start pinging and send a shutdown command to the target(s).

Uninstall individual update
This action enables you to uninstall an individual Windows Update by specifying its Microsoft KB ID number. Ex: KB123456.
**Hide / unhide updates**

**List all hidden updates**
This action will list any/all updates that have been marked as 'hidden' on target hosts.

**Create/modify list of specific updates for hiding**
Use this list to specify which updates are hidden when you initiate the 'Hide updates' action in BatchPatch.

If this list is empty, BatchPatch will hide any/all visible updates.

If this list is populated, BatchPatch will hide only updates that are in the list.

Matching is done by comparing the update title to the text of each item in the list. If the text of any item in the list below is contained in the update title, the update will be hidden. To guarantee uniqueness, we recommend entering the KB IDs of the updates that you would like to hide, though you may provide a different search string if you prefer. For example:

KB123456
KB234567
KB345678

**Hide updates**
This action will hide any/all visible updates on target hosts, unless you 'Create/modify list of specific updates for hiding,' in which case this action will hide only the updates in the list.

**Create/modify list of specific updates for unhiding**
Use this list to specify which updates are unhidden when you initiate the 'Unhide updates' action in BatchPatch.

If this list is empty, BatchPatch will unhide any/all hidden updates.

If this list is populated, BatchPatch will unhide only updates that are in the list.

Matching is done by comparing the update title to the text of each item in the list. If the text of any item in the list below is contained in the update title, the update will be unhidden. To guarantee uniqueness, we recommend entering the KB IDs of the updates that you would like to unhide, though you may provide a different search string if you prefer. For example:

KB123456
KB234567
KB345678

**Unhide updates**
This action will unhide any/all hidden updates on target hosts, unless you 'Create/modify list of specific updates for unhiding,' in which case this action will unhide only the updates in the list.

**Abort download / installation**
If you are in the middle of a Windows Update download or installation process, you can safely abort it by selecting this menu item. However, this process does not complete instantaneously. If you absolutely must end the download/update process immediately without waiting for the Windows
Update Agent to safely abort the operation, then we recommend using the “Kill remote BatchPatch process” instead. If you had originally selected to perform an 'update + reboot' or 'update + shutdown' action, aborting the download / installation will also prevent the reboot or shutdown from executing.

**Kill remote BatchPatch process**

Using this action will cause BatchPatch to immediately terminate all of its remote processes on the target host(s). If you had originally selected to perform an 'update + reboot' or 'update + shutdown' action, killing the process will also prevent the reboot or shutdown from executing.

**Reattach orphaned Windows Update process**

If a previous Windows Update action was mid-execution when you closed BatchPatch, you can use this method to reconnect a BatchPatch row to a Windows Update process that is still executing on a target host. This enables you to continue monitoring the progress of the update process and optionally initiate a reboot or shutdown when it completes.

**View BatchPatch.log**

BatchPatch will remotely read and display the BatchPatch.log file from target computers. The BatchPatch.log file default location is C:\Program Files\BatchPatch on all target computers, but this location can be modified by changing the value listed in Tools > Settings.

**View WindowsUpdate.log**

BatchPatch will remotely read and display the C:\Windows\WindowsUpdate.log file from target computers.

**wuaclt.exe /resetauthorization /detectnow**

Executes the command on target computers.


**wuaclt.exe /reportnow**

Executes the command on target computers.


**Get Windows Update configuration**

Displays the WSUS server that the selected hosts are configured to use. Typically most organizations use Group Policy to control which WSUS server its computers point to. When Group Policy has been used to set this value, the following registry key is created:

HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate\WUServer

BatchPatch attempts to read this registry value. If it doesn't exist, then the host has not been configured to use a WSUS server and will instead still use Microsoft Update.

**Opt-in to Microsoft Update**

For computers that are not managed by a WSUS or other update server, selecting this action is equivalent to launching the Windows Update GUI on a target computer and clicking the option to “Get updates for other Microsoft products.” This action only needs to be performed one time. Once completed, the Windows Update GUI will display a label that says “You receive updates: For Windows
and other products from Microsoft Update.”

**Opt-out of Microsoft Update**

If you have already opted-in, you may use this action to opt-out and de-authorize the target computer for Microsoft Update. When this action has been completed, the Windows Update GUI will display a label that says “You receive updates: For Windows only.”

**Generate consolidated report of update history (Windows Update Agent)**

BatchPatch provides you with the ability to retrieve the history of all Windows Updates actions from
target computers' Windows Update Agent database. The report includes the update title, the action performed (installation/uninstallation), the date the action was performed, the status of the action (success/failure), as well as the application that performed the action.

You can optionally include or exclude specific updates, based on the update title, using the inclusion/exclusion fields in the Update History Report Settings Form. However, note that exclusion entries will override inclusion entries in the event of both criteria being satisfied.

Generate consolidated report of update history (Win32_QuickFixEngineering)

This action tells BatchPatch to query the Win32_QuickFixEngineering class on target computers for the list of updates/hotfixes that have been installed the target. Note, Win32_QuickFixEngineering is the same class that is queried by the 'Get-Hotfix' PowerShell cmdlet that you might already be familiar with. The updates/hotfixes included in this report will generally not be the same as the ones included in the Windows Update Agent history report because Windows records update history in different locations depending on the mechanism used to install the update.

Deploy software/patch/script

With BatchPatch you can very easily deploy to remote computers just about any type of software package, script, executable file, registry key etc. There are numerous tutorials and videos available on our website, so please check it out: Software Deployment

IMPORTANT: In order to execute a remote installation with BatchPatch, you must first determine the proper command line switch/parameter to initiate a "silent" or "quiet" installation.

A proper silent/quiet installation will complete without any user interaction, but if you execute an installation without specifying the correct silent/quiet parameter, the hidden remote process will hang.
indefinitely without ever completing.

Different installation packages have different command line switches. The silent/quiet switch might be
any one of the following, or something completely different, depending on how the installer was
created: /S, /s, -S, -s, /silent, -silent, /Q, /q, -Q, -q, /quiet, -quiet.

BatchPatch makes it easy to deploy standalone MSI, MSP, MSU, EXE, REG, VBS, PS1 and virtually
any other type of file to remote computers. The key here is to test on a single machine before
attempting deployment on many computers. Remember that not all standalone patch files will support
the same command line switches/options, so it’s up to you to test everything thoroughly before
attempting a mass deployment.

For more information and a specific example, see “Using BatchPatch to Deploy Software, Standalone
Patches, Scripts, Registry Keys, and More” in the tutorials section of this Administrator's guide.

**Create/modify deployment**

This is where you actually setup the deployment to be executed

For more information and a specific example, see “Using BatchPatch to Deploy Software, Standalone
Patches, Scripts, Registry Keys, and More” in the tutorials section of this Administrator's guide.

**Execute deployment**

This is how you execute the deployment you setup in the “Create/modify deployment” screen.

For more information and a specific example, see “Using BatchPatch to Deploy Software, Standalone
Patches, Scripts, Registry Keys, and More” in the tutorials section of this Administrator's guide.

**Remote process/command**

Use Remote Process 1 or Remote Process 2 for generic scripts, programs, or commands that you want
to run on a remote host when you do *not* need to view the console output of the command. Remote
Process 1 and 2 also support all PsExec switches. After executing, BatchPatch will wait until the
remote process terminates before it displays *only* a success or error code.

Use Remote Process 3, Remote Process 4, or saved user-defined commands for viewing the console
output of a remote command such as ipconfig, tasklist, wmic etc. BatchPatch will execute the remote
command and then display its output. PsExec switches are not supported.

**Create/modify remote command 1**

Create the command that you want to execute on the selected target hosts

Use Remote Process 1 or Remote Process 2 for generic scripts, programs, or commands that you want
to run on a remote host when you do *not* need to view the console output of the command. Remote
Process 1 and 2 also support all PsExec switches. After executing, BatchPatch will wait until the
remote process terminates before it displays *only* a success or error code.

**Execute remote command 1**

Execute the command that you created

**Create/modify remote command 2**

Create the command that you want to execute on the selected target hosts
Use Remote Process 1 or Remote Process 2 for generic scripts, programs, or commands that you want to run on a remote host when you do *not* need to view the console output of the command. Remote Process 1 and 2 also support all PsExec switches. After executing, BatchPatch will wait until the remote process terminates before it displays *only* a success or error code.

**Execute remote command 2**
Execute the command that you created

**Create/modify remote command 3 (logged output)**
Create the command that you want to execute on the selected target hosts
Use Remote Process 3, Remote Process 4, or saved user-defined commands for viewing the console output of a remote command such as ipconfig, tasklist, wmic etc. BatchPatch will execute the remote command and then display its output. PsExec switches are not supported.

**Execute remote command 3(logged output)**
Execute the command that you created

**Create/modify remote command 4 (logged output)**
Create the command that you want to execute on the selected target hosts
Use Remote Process 3, Remote Process 4, or saved user-defined commands for viewing the console output of a remote command such as ipconfig, tasklist, wmic etc. BatchPatch will execute the remote command and then display its output. PsExec switches are not supported.

**Execute remote command 4 (logged output)**
Execute the command that you created

**Create/modify user-defined commands (logged output)**
Create the command that you want to execute on the selected target hosts

**Execute user-defined commands (logged output)**
Execute the command that you created

**Local process/command**
Sometimes you might find it necessary or helpful to be able to run commands, processes, or scripts locally on the computer that is running the BatchPatch console. You can use the “Local process/command” action to do this. Executing a command or process using the “Local process/command” action in BatchPatch is essentially equivalent to executing that same command at a CMD prompt on the computer running BatchPatch.

However, if you have a script or custom program that accepts a computer name as a parameter, you can have BatchPatch pass the computer in the Hosts column into your script.

For example:
```cscript.exe c:\scripts\myVbscript.vbs $computer```

If the hosts column contains a computer named “Exchange01,” when the above command is executed,
the final/actual command that will be executed will be:

cscript.exe c:\scripts\myVbscript.vbs Exchange01

*Create/modify local command 1*

*Execute local command 1*

*Create/modify local command 2*

*Execute local command 2*

*Create/modify user-defined commands*

The user-defined section enables you to store commands for future use. Any command that you create in the “Create/modify user-defined commands” dialog window will appear hard-coded into BatchPatch under the “Execute user-defined commands” menu item.

*Execute user-defined commands*

The user-defined section enables you to store commands for future use. Any command that you create in the “Create/modify user-defined commands” dialog window will appear hard-coded into BatchPatch under the “Execute user-defined commands” menu item.

*Job queue*

The job queue enables you to create a custom set of actions to execute on target machines, all with just a single click.

*Create/modify job queue*
Simply select an action in one of the left-panes, and then either use the right-arrow button or a double-click to move it over to the middle-pane. Once in the middle pane you can choose to “Execute now,” which will execute that queue for the highlighted rows in the grid, or you can choose to “Apply queue to row(s) without executing.” Selecting this option will assign that queue to the highlighted rows without executing it immediately. It can later be executed for those rows by highlighting the rows and selecting 'Actions > Job Queue > Execute job queue.' You may also simply save a job queue by giving it a title and using the double-right-arrow button to move it over to the 'Saved Queues' grid. Once in the saved queues, it will appear hard-coded in the BatchPatch menu under 'Actions > Job Queue > Execute saved job queues.'

Note, the 'Special' item to “Wait for host to go offline and come back online” will not only wait until the host reboots and is pingable, but it also uses a WMI query to ensure the target host is responding to incoming requests.

The 'Stop queue execution if previous action fails/errors' can be inserted after custom scripts in the job queue to enable BatchPatch to terminate the current job queue if a custom script does not execute successfully.

The 'Abort multi-row queue sequence if previous action fails/errors' can be inserted after custom scripts in the job queue to enable BatchPatch to abort the entire parent multi-row queue sequence of an executing job queue if the custom script does not execute successfully.

**Execute job queue**

Executes the job queue that is applied to the selected row(s).

**Execute basic multi-row queue sequence**

Executes the job queue for all selected rows, in sequence, one row at a time, in the order the rows were selected. Instead of each selected row being executed independently in its own thread, all of the selected rows will be strung together in a single execution sequence. This means that only one execution thread will be launched. It will process the first selected row's job queue, then the second selected row's job queue, then the third selected row's job queue, and so on. This feature allows you to do more advanced sequences. For example, let's say that you need to reboot computers in a special order, and computer 2 cannot go offline until computer 1 comes back online after reboot. In that case you would create a job queue for each computer in the sequence. The first action in each queue could be to reboot the computer, with the second action being “Wait for host to go offline and then come back online.” When you execute the basic multi-row sequence, the first selected row will initiate a reboot, then it will wait until the computer goes offline and comes back online. Once the computer is back online, the next selected row will initiate a reboot, and so on.


**Create/modify advanced multi-row queue sequence**

You can use the advanced multi-row queue sequence to execute an action or a set of actions on one or more target computers. When those target computers complete the specified actions, another target computer or set of computers could be triggered to execute an action or set of actions. When the second set of computers is finished, a third set of computers could be triggered, and so on. If you need to skip a particular row that has been included in a sequence, you can simply disable that row (Actions > Disable/enable) before it is submitted for execution. In a single sequence you can integrate scripts,
deployments, updates, reboots, and pretty much anything else that BatchPatch has to offer. See
http://batchpatch.com/advanced-multi-row-queue-sequence for detailed explanation and usage
instructions.

**Execute advanced multi-row queue sequence**
You can use the advanced multi-row queue sequence to execute an action or a set of actions on one or
more target computers. When those target computers complete the specified actions, another target
computer or set of computers could be triggered to execute an action or set of actions. When the second
set of computers is finished, a third set of computers could be triggered, and so on. If you need to skip a
particular row that has been included in a sequence, you can simply disable that row (Actions >
Disable/enable) before it is submitted for execution. In a single sequence you can integrate scripts,
deployments, updates, reboots, and pretty much anything else that BatchPatch has to offer. See
http://batchpatch.com/advanced-multi-row-queue-sequence for detailed explanation and usage
instructions.

**Pause advanced multi-row queue sequence**
You can pause an advanced multi-row queue sequence that is already in progress. You must perform
this action on an 'ExecutionRow' for it to take effect. Any rows that are currently executing will
continue executing until they are complete. However, rows that have not yet begun execution will be
paused until you decide to unpause the sequence.

**Unpause/continue advanced multi-row queue sequence**
Use this menu item to unpause/continue a previously paused advanced multi-row queue sequence. You
must perform this action on an 'ExecutionRow' for it to take effect.

**Copy file / folder**

**Create/modify file or folder copy**
Use this feature to copy files to target computers. You'll select a source file or folder to be copied, and
then you'll enter a destination folder path. The destination folder path is local to the target computers.
So, for example, you'll need to type the path as follows: C:\MyDestinationFolder. Then when you
execute the copy, BatchPatch will copy the single selected file or entire contents of the specified source
folder, including subfolders and files. The copied file(s) will be placed into the destination folder,
C:\MyDestinationFolder, on each target machine that the task is executed against.

**Execute file/folder copy**
Highlight the desired target machines to receive the copied files, and then select this action to execute
the copy.

**Task scheduler**
Use the task scheduler to set a specific date/time to run a BatchPatch action. Note that the scheduler is
disabled by default. After you've created a scheduled task, you must enable the scheduler by clicking
on the “clock” icon in the upper-right corner of the BatchPatch window. You may also automatically
enable the task scheduler when BatchPatch launches by ticking the appropriate box in Tools > Settings.
Create/modify scheduled task

Select the options that you want for a particular scheduled task. If you don't want to run a task at a specific time but instead want to run the task as soon as BatchPatch detects a target computer online, tick the box to enable this option. This feature is particularly nice for when you need to execute a task on user laptops since users might not always have their laptops connected to the corporate network.

Note, if a computer is connected to the network for only a brief period of time, say a couple minutes, it might not be long enough for BatchPatch to detect its presence. BatchPatch uses a single thread to check the online status of any computer in the grid that has the “Run task immediately upon detecting target computer online” option enabled. It can take up to a few seconds for this execution thread to determine whether or not an individual computer is online. Since each computer is checked sequentially, the length of time required to check the entire list of computers utilizing this setting is dependent on the length of the list, the performance of the network, and the number of computers in the list that are offline at any given time (an offline host will take longer to check than an online host).

Clear scheduled task

Use this option to clear the scheduled task for a particular row or rows in the grid

Specify alternate logon credentials

When you use Integrated Security, BatchPatch authenticates with remote/target computers using the account that you use to launch the BatchPatch.exe process on this computer, which is usually the same account that you are currently logged on with.

Note: If you specify Alternate Credentials (instead of using Integrated Security) and then save your grid to a .bps file, the passwords in the .bps file will be obfuscated. However, anyone who has a copy of the .bps file could obtain the actual deobfuscated passwords, so it is very important that you do not share a password-containing .bps file with anyone who should not know those passwords.

Using Integrated Security with a Domain Account:

1. The domain account that you use to launch BatchPatch must be a member of the local administrators group on the target computer.
Using Integrated Security with a Local Account:

1. The local account that you use to launch BatchPatch must also exist on the target computers, defined with the exact same username and password that is defined on the computer running BatchPatch.

2. If the local account you are using to run BatchPatch is THE built-in administrator account on the target computers, the following registry DWORD must be set to 0 on the target computers. When this DWORD is set to 0, the built-in administrator account is set to full-token mode, and BatchPatch will work properly. However, if it's set to 1, the built-in administrator account is put in admin-approval mode, which will prevent most BatchPatch actions from completing successfully for those target computers:

   HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system\FilterAdministratorToken
   (only required for Vista/7/2008/2008R2/2012)

3. If the local account you are using to run BatchPatch is not THE built-in administrator account on the target computers, but instead is just a regular named local account that is a member of the local administrators group on the target computers, then the following registry DWORD must be set to 1 on the target computers:

   HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system\LocalAccountTokenFilterPolicy
   (only required for Vista/7/2008/2008R2/2012)

Using Alternate Credentials with a Domain Account:

1. The account that you specify must be a member of the local administrators group on the target computers.

Using Alternate Credentials with a Local Account:

1. The account that you specify must be a member of the local administrators group on the target computers.

2. If the local account that you specify is THE built-in administrator account on the target computers, the following registry DWORD must be set to 0 on the target computers. When this DWORD is set to 0, the built-in administrator account is set to full-token mode, and BatchPatch will work properly. However, if it's set to 1, the built-in administrator account is put in admin-approval mode, which will prevent most BatchPatch actions from completing successfully for those target computers:

   HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system\FilterAdministratorToken
   (only required for Vista/7/2008/2008R2/2012)

3. If the local account that you specify is is not THE built-in administrator account on the target computers, but instead is just a regular named local account that is a member of the local administrators group on the target computers, then the following registry DWORD must be set to 1 on the target computers:
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system\LocalAccountTokenFilterPolicy
(only required for Vista/7/2008/2008R2/2012)

Wake On LAN

Wake-on-LAN (WOL) is an Ethernet-based standard that enables properly configured computers to be turned on or “awakened” by a network message. Typically, in order to properly configure a computer to respond to Wake-on-LAN packets, you need to enable it both in the computers’ BIOS as well as in Windows on the network adapter’s settings page. There are numerous resources on the web that explain how to enable Wake-on-LAN, and so we have chosen not to explain it here since not all computers will require identical setup steps.

Wake On LAN (requires MAC)

This action sends the so-called “magic packet” to target computers, allowing properly configured computers to be turned on or “awakened” by a network message.

Modify broadcast address / port

The default broadcast address is 255.255.255.255. A special definition exists for this address. It is the broadcast address of the zero network or 0.0.0.0, which in Internet Protocol standards stands for this network, i.e. the local network. Transmission to this address is limited by definition, in that it is never forwarded by the routers connecting the local network to other networks.

BatchPatch allows you to modify the broadcast address, which means you can direct Wake-on-LAN packets to other subnets if you choose. However, note that routers are typically configured to disallow subnet-directed broadcasts. This means that if you don't modify your routers' configurations to allow subnet-directed broadcasts, then when BatchPatch sends Wake-on-LAN packets to other subnets, those packets might never reach their destinations, with improperly configured intermediary routers being responsible for dropping those packets.

BatchPatch additionally allows you to modify the the port used for Wake-on-LAN packets. BatchPatch defaults to port 7 for this setting because conventionally Wake-on-LAN implementations use port 7. However, any port can work.

Email notification

The email notification action lets you email a text and/or HTML version of the grid either on demand, or as a scheduled task, or as part of a job queue. Configure the default email notification settings under Tools>Settings>Email Notifications

Override default email notification settings

BatchPatch gives you the option to override the default email notification settings on a per-row basis. One possible way to setup email notifications would be to configure the default body text under Tools>Settings>Email Notifications to be “$row,” which would enable you to have each row send its own email notification at the end of a job queue, for example, or at a scheduled date/time. But maybe you also want to email the entire grid or all grids in BatchPatch at a specific date/time, perhaps at the end of a scheduled maintenance window. You could accomplish this by setting up a “dummy” row in BatchPatch with a scheduled task to send an email notification at a specific time. Override the default body text with “$grid” or “$allgrids” to have BatchPatch email you everything in the current grid (or
everything in all grid tabs) instead of just the information for a single row.

**Send email notification**

Send an email notification on-demand.

**Import notes or MAC addresses**

This feature enables you to import MAC addresses or Notes for hosts that are already in the grid. For example, let's say you have a BatchPatch grid open with the following hosts listed:

host1
host1
host3
host4

You may create a # delimited file to import MAC addresses, or you may create a | delimited file to import Notes. Highlight the rows that you want to import notes or MACs for, and then select **Actions > Import notes or MAC addresses** and browse to the location of the | or # delimited text file you've created. See below for details.

**Import Notes column for pre-populated Hosts column...**

You can maintain a separate text file just to hold the Notes for given hosts. So, a text file in this case might look like:

host1|notes for host1
host2|notes for host2
host3
host4|notes for host4

**Import MAC address column for pre-populated Hosts column...**

You can maintain a separate text file, if you wish, just to hold the MAC addresses for given hosts. So, a text file in this case might look like:

host1#CC123DB123A1
host2#A31D3DB114B2
host3#
host4#B214DD1B24C1

**Modify category, description, location, notes, etc**

This menu items provides you with an interface to modify user-editable fields:'Category', 'Description', 'Location', 'Notes', 'Notes2'

**Clear column contents**

Just like it sounds, this action lets you clear the contents of specific columns.
Clear all but Hosts, MACs, and Notes

Clear all but Hosts and MACs

Clear all but Hosts and Notes

Clear all but Hosts

Clear specific columns...

Move host(s) to different tab
This option lets you most hosts from one tab to another.

1. Select an existing tab page or create a new tab page as a destination for the selected hosts(s).
2. Click OK to move the currently selected/highlighted hosts to the destination grid. Any actions currently in progress on the selected hosts will be orphaned and/or killed.

Insert row
You can use this menu item to insert a blank/new row above the currently selected row.

Disable / enable row(s)
Disabling a row will color it gray. It will be excluded from any action that is executed while it is disabled.

Remove row(s)
Once you remove a row from a grid, you will not be able to get it back. If you remove a row while an action is executing, it's possible that the action will get terminated immediately, but in some cases the action might continue processing until it completes, though any indication of what the action's status is will be unknown once the row has been removed.

TOOLS

Row template configurator
Each grid can have its own row template. When enabled, a host that is added to the grid will automatically receive the row template cell contents. This is helpful if you want to automatically apply a scheduled task or job queue to new hosts that are added to the grid.

Row execution interval...
The row execution interval is the number of seconds the execution thread pauses after launching an action for each row before it moves on to the next row's action. Actions are performed on hosts, sequentially, in the order the rows are selected.

For example, let's say that you set the row execution interval to 60 seconds before you highlight 3 hosts to reboot. When you finally execute the reboot you'll notice that the first selected host starts rebooting, but 60 seconds passes before the second host starts rebooting, and then another 60 seconds passes before the third host begins to reboot.

Note, the row execution interval does not apply to “readonly” operations, such as the “Get
Information” actions.

**Customize visible columns...**

This is the same menu that appears when you right-click on any column header. It allows you to show or hide columns in the grid.

**Customize visible toolstrip buttons...**

Just about every action in BatchPatch has a toolstrip button. However, since there is limited space on the toolstrip, you may use this dialog window to customize which actions appear on the toolstrip and which ones are hidden. (Note, you can also rearrange the order of the visible buttons by using ALT-LeftClick to drag buttons to new positions in the toolstrip)

**Reset toolstrip to default configuration**

This option lets you reset the toolstrip to the original default settings.

**Delete remote working directory**

BatchPatch creates a folder on remote hosts in order to execute most actions. If you need to remove the remote working directory, you may use this menu item to do so. The directory location is specified under Tools > Settings.

**Download Microsoft Offline Scan File**

This option may be used with 'cached mode' or 'offline mode' to download the WsusScn2.cab file that Microsoft publishes monthly. Please see Cached Mode and Offline Updates for more information.

**Download offline updates repository**

This feature lets you pre-download offline security updates for deployment to offline computers using BatchPatch offline cached mode. For high security networks where it is not possible to copy a .bpurl file (BatchPatch text file containing a list of offline update URLs) from the offline network to a computer with internet access in order to download the offline security update files, this feature allows the administrator to download the offline security update files first, en masse, to copy to the high security offline network. Please see Cached Mode and Offline Updates for more information.

**Export saved commands, deployments, job queues**

Use this option to export the user-defined/custom commands, deployments, job queues, messages to logged-on users, categories, descriptions, locations, clear column contents configurations, etc that you've created in BatchPatch to a single text file (XML). You may then use the 'Import saved commands, deployments, job queues' option to import this file to a different instance of BatchPatch.

**Import saved commands, deployments, job queues**

Use this option to import the user-defined/custom commands, deployments and job queues that you've previously exported to a text file (XML) using the 'Export saved commands, deployments, job queues' menu item.
Run BatchPatch as a service
See section: 'Run as service settings'

Settings...

General Settings

Grid export directory for job queue and scheduler:
The directory you specify in this field will be used as the output folder for the Job Queue and Task Scheduler when they execute either of the following two actions, allowing you to save a snapshot of the current grid or all grids at a given point in time:
Save HTML current-grid export
Save HTML all-grids export

Low C: Disk Space Warning Threshold
This setting works in conjunction with the “Get C: disk space” action. If the amount of free space on a target host is less than the value specified in this field (MB), the graphical representation will be painted red instead of the default color when the “Get C: disk space” action is executed for a given host.

Concurrent Thread Maximum (0 == unlimited)
This setting gives you maximum control over performance in BatchPatch. The default value is 50. BatchPatch is a multi-threaded application, with virtually every action running in its own background worker thread. You can limit the number of concurrent background worker threads with this option in order to improve performance.
This settings applies to only the following actions:
- Windows Update
- Local Process/Command
- Remote Process/Command
- Deployment

Concurrent File-Copy Operations Maximum (for Deployment Action)
When you use the Deployment action to install software remotely or push a script to remote targets, BatchPatch copies the installation files or script file to those target machines. However, since BatchPatch allows the user to execute many threads simultaneously (see Concurrent Thread Maximum setting above), if there are many Deployment threads running at the same time, there could be a significant bottleneck during the portion of the operation that is responsible for copying the files to the targets. Imagine 100 threads all try to copy the same local file(s) to 100 different target computers at the same time (especially if the files to copy are large). It wouldn't be ideal. So, BatchPatch has a separate queueing mechanism built-in specifically for the file-copy operation in the Deployment method. In general it's probably a good idea to keep this number relatively low, unless the file that you are deploying is very small, in which case it won't make much difference either way.

Remote Desktop Connection Port
The default remote desktop connection port in Windows is 3389. If your hosts are set to listen for RDP
packets on a different port, you can use this setting to modify the port BatchPatch uses to launch remote desktop connections, so that it matches the listening port of your hosts.

**.bps/.bpt file password security – PBKDF2 iterations**

When you encrypt the contents of a .bps/.bpt file by selecting 'File > Password protect,' BatchPatch uses PBKDF2 (Password Based Key Derivation Function 2) to derive an encryption key (for 256-bit AES encryption) from the password that you specify. Setting a large, random number of PBKDF2 iterations increases the protection against brute-force attacks.

This value may be set from 10,000 to 1,000,000. The default is set to 50,000. The greater the number of iterations, the longer it takes to derive a key from the passphrase, and the greater the protection against brute-force attacks. However, in all cases a long, non-dictionary, high-entropy password is of paramount importance to prevent a brute-force attack from being successful.

Please note that the greater the number of iterations, the longer it will take to save and open password-protected files. There is always a balance between convenience and security, so try to pick the largest number that doesn't frustrate you with waiting too long to save and open grids.

Also note, if you modify the 'PBKDF2 Iterations' value under 'Tools > Settings > General', upon clicking OK BatchPatch will automatically re-save any currently open grids that have previously been password-protected.

**IMPORTANT:** If you have any other password-protected .bps/.bpt files saved to disk that are not currently open in BatchPatch, when you try to open them at a later date after setting a new 'PBKDF2 Iterations' value, they will fail to open with an 'Incorrect Password' error. In that case you would need to open those files under the previously configured 'PBKDF2 Iterations' value, then reset the 'PBKDF2 Iterations' value to the new number, and then BatchPatch will re-save the grids using the new value.

**Use system default log file viewer instead of BatchPatch built-in viewer**

When you use BatchPatch to view the BatchPatch.log or WindowsUpdate.log files, you can use this option to have those .log files open in whatever .log file viewer is configured as the default .log viewer on your computer, such as Notepad, for example. If this option is not ticked, BatchPatch will use its own built-in viewer.

**Force pinger to always use IPv4 addresses**

When this option is ticked, BatchPatch will do a DNS lookup to obtain the IPv4 address of the host, and it will subsequently use that IPv4 address when it pings the host. If this option is unticked, BatchPatch will ping the first address it finds for the host, which could be IPv4 or IPv6.

**Global exclusions list for automatic services in stopped state**

Services in this list will be excluded when checking for stopped automatic services on target computers ('Actions > Get information > Get automatic services in stopped state).

For example, if 'Software Protection' is included in this list when you check for stopped automatic services on a target computer, then even if 'Software Protection' is the only service that is set to automatic and stopped on the target computer, the action will report that all automatic services are started.
Automatically start host status check (LED colors) on startup/new tab/open

BatchPatch has the ability to check the online / offline status of all hosts listed in the grid, independently of all other actions. In any grid, you can stop or start the host status check by clicking the “LED” icon column header. When you start this check, a single thread will be created to ping each host in the grid, sequentially.

Green == Host is pingable
Yellow == Host is currently being checked
Orange == Host does not exist or cannot be found
Red == Host exists and can be found, but pings to the host are timing out
Pink/Gray == Row is excluded from host status check
Gray == No information for the row

--Middle-click on the LED column header == clear all LEDs and reset to gray
--Middle-click on the LED image for a specific row to disable that row from the host status check. The LED will turn a pink-gray color.
--Shift-MiddleClick on any row's LED == turn the LED blue to indicate completion, if you like. A blue LED will stay blue as long as the host is pingable/online.

Note, while the host status check is convenient to use at times, it is not the only way that the “LED” indicator icons will change color. In fact, if you leave the host status check disabled / off, when you ping a host or reboot a host, the LED for that host will be colored according to the same rules as are listed above. That said, it is generally not necessary to have the host status check begin automatically at startup, which is why this setting is disabled by default.
Enable Task Scheduler on startup
If this setting is enabled, the task scheduler will always be running when BatchPatch is launched.

Show 'Getting Started' window at startup
If you want to display the “Getting Started” window every time BatchPatch launches, enable this settings.

Check for updates on startup
BatchPatch will automatically check for updates to the software when BatchPatch is launched, unless you disable this setting. If there is an update available, BatchPatch will display a notification window and a download link to the newer version.

Remember open tabs from last session when launching BatchPatch.exe
If this box is ticked, BatchPatch will remember the tabs that were open during the previous session, and it will attempt to load them automatically when a new instance of BatchPatch is launched, if they were saved and still exist in the same location as when BatchPatch was last used. Note that if you are using multiple instances of BatchPatch, only the first instance launched will auto-load the previous session's tabs.

Remember open tabs from last session when launching .bps, .bpt, or .bpp
If you have registered the .bps, bpt, and .bpp file types so that you can double-click on a .bps file to launch it directly in BatchPatch, you may optionally still have the last session's tabs remembered so that when you launch the .bps, .bpt, or .bpp file, not only will that file open, but so will all the previously open tabs from last session. If this option is not ticked, but the Remember open tabs from last session when launching BatchPatch.exe is ticked, then the only time the open tabs from the previous session will be loaded is when launching a new fresh instance of BatchPatch.exe.

Minimize button: Left click min to taskbar / right click min to tray
This option controls whether a right-click or left-click will minimize BatchPatch to the system tray or to the task bar.

Minimize button: Left click min to tray / right click min to taskbar
This option controls whether a right-click or left-click will minimize BatchPatch to the system tray or to the task bar.

Grid Preferences

Hosts are considered offline after X ping timeouts
When you reboot a host, BatchPatch will automatically start pinging it. You can also manually ping any host using the Start Pinging action. In either case, BatchPatch uses this setting to determine how many ping TimedOut or DestinationHostUnreachable responses will trigger an offline status notification in BatchPatch. Offline status notifications are printed to the 'All Messages' column, and if you have Ping Status Alerts (see Actions > Ping status alerts) enabled, then you will receive an audible and/or email alert as well.
Automatically stop pinging when host comes online after having been offline

When you reboot a host, BatchPatch will automatically start pinging it. You can also manually ping any host using the Start Pinging action. In either case, BatchPatch uses this setting to determine if it should automatically stop pinging a host that has come online after having been offline. Hosts are considered offline according to the previous setting. When a host comes online after having been offline, BatchPatch will turn the ping reply text blue along with the LED image icon for that row. If this checkbox is ticked, the host will stop pinging and the row coloring will remain blue, accordingly. If this checkbox is unticked, then after the host is back online and 5 successful “blue” pings have occurred, BatchPatch will reset the blue coloring back to black and continue to ping the host. The 'All Messages' column will still retain the datetime stamps for when the host went offline and when it came back online.

Enable row sorting

Row sorting is disabled by default to prevent accidentally executing a sort operation, which cannot be undone. However, you may enable row sorting with this setting.

Show tab header alert images

When this setting is enabled BatchPatch will display an alert image in the tab page header directly to the left of the tab title text any time a host in the grid is marked 'OFFLINE.' The alert will automatically be cleared when all hosts in the grid are back online. However, you may also clear an alert at any time by right-clicking on the tab page header and selecting the menu item to “Clear alert.”

Hide 'View cell contents' right-click context menu-item

We strongly encourage you to use the middle-click button to display the cell contents of any cell you click on. It's faster and simpler than using the right-click context menu item. As such, we give you the option to hide the right-click context menu in order to reduce visual clutter.

Show ping status alerts image column when adding hosts to new grid

This setting controls whether or not the 'Ping Status Alerts' image/icon column is made visible automatically by BatchPatch when you add hosts to a new/empty grid.

Prevent duplicate host names from being added to grid

If selected, BatchPatch will prevent a host from being added to a grid that already contains that host.

Use custom timestamp in 'All Messages' column

The default timestamp in the 'All Messages' column only includes the time of day. However, you may wish to have the timestamp be displayed in a specific format. You can customize the look of the timestamp with this setting.

Allow BatchPatch to auto-resize column widths to a max of

It's usually easier to allow BatchPatch to auto-resize column widths. However, sometimes programmatic resizing is less than ideal, in which case you can disable this option if you prefer.

Allow BatchPatch to auto-resize the window width to a max of

It's convenient to allow BatchPatch to automatically expand the size of the window to accommodate additional columns, as they are made visible when you execute new actions. However, if you want to
disable this setting, you may. This setting only applies to Tab mode and does not apply to Multi-grid mode. (See the View menu for more details on Tab mode vs Multi-grid mode)

**Allow BatchPatch to unhide columns automatically**

It's convenient to allow BatchPatch to automatically unhide columns as new actions are executed in the BatchPatch grid. If you prefer, you may handle column hiding and unhiding on your own, but it becomes confusing to pay attention to which columns need to be open for which actions, and so it is recommended to let BatchPatch handle this for you. Use the *except these columns* button to select columns that BatchPatch should *not* auto-unhide.

**Reset columns on startup and on new tab creation**

If you uncheck this setting, upon closing and reopening BatchPatch you will notice that whatever columns were visible when BatchPatch was last closed will also be visible when you launch BatchPatch.

**Reset window size on launch (applies only to tab mode)**

Unchecking this box will cause BatchPatch to remember the size of the window the last time BatchPatch was closed.

**Auto-resize settings for 'View cell contents' (middle-click) tooltip**

Choose a maximum height and width for the tooltip that is displayed when you middle-click a cell (or when you choose the right-click > View cell contents option.

**Windows Update Agent Settings**

**Search Preferences**

When you initiate any of the Windows Updates actions, BatchPatch uses these search preferences to look for available updates on the update server. Administrators commonly prefer to only search for software updates rather than also searching for driver updates, which is why the default is set to search for software updates only. However, you may alternatively use the 'Important' setting to emulate Microsoft's criteria for 'Important' vs 'Optional' updates. If you then also include 'Recommended' updates, you will produce the same results as if you checked/enabled the "Give me recommended updates the same way I receive important updates" setting that is available in the Windows Update GUI on standalone computers. This setting bundles all the 'Recommended' updates in with the 'Important' updates.

**Server Selection**

Default / Managed: Uses the target computer's existing configuration to determine where to search for updates.

Windows Update: Bypasses the target computer's configuration and searches for updates on Microsoft's public server. Includes only Windows updates.

Microsoft Update: Bypasses the target computer's configuration and searches for updates on Microsoft's public server. Includes Windows updates AND updates for other Microsoft products. Before using Microsoft Update, target servers must be opted-in to the service. You can use **Actions > Windows Updates > Opt-in...** to handle this process.
**Update Classification Filtering**

Every Windows Update is categorized into one of the following classifications.

- Critical Updates
- Security Updates
- Definition Updates
- Update Rollups
- Service Packs
- Feature Packs
- Drivers
- Tools

For WSUS environments, we recommend setting the "Search Preferences" to include both software and drivers, and then checking every box in the “Update Classifications” section. Approval settings on your WSUS server will control which updates are available to computers. No additional filtering should be necessary.

For non-WSUS environments, we suggest setting the "Search Preferences" to include just software, and then check the boxes for Critical Updates, Definition Updates, and Security Updates, at a minimum. Alternatively, to emulate how Microsoft delivers updates to a standalone computer, use the 'Important' search option, with or without 'Recommended,' and then include all Update Classifications.

**Update Date Filtering (skip download / installation of recently deployed updates)**

This filter instructs BatchPatch to compare the current date to the LastDeploymentChangeTime property of each updates. The LastDeploymentChangeTime property is printed as a date (yyyy-MM-dd) next to each update listed in the BatchPatch.log file. You can see this easily in the 'Remote Agent Log' column when performing a check for available updates in BatchPatch.

When updates are obtained from 'Windows Update' or 'Microsoft Update,' the LastDeploymentChangeTime property is equivalent to the date the update was published by Microsoft.

When updates are obtained from WSUS, the LastDeploymentChangeTime property is equivalent to the date the update was approved in WSUS.

BatchPatch will only download/install updates that were published / approved at least X days ago. For example if you set this value to 30, updates that were published / approved any time between today and 29 days ago will **not** be installed by BatchPatch. Only updates that were published / approved 30 or more days ago will be installed.

**EULA behavior**

Occasionally a Windows Update will require the end-user to accept a EULA (End User License Agreement) in order to install the updates. BatchPatch can automatically accept the EULA and proceed with the installation when this box is checked. If this box is unchecked, BatchPatch will skip over any updates that require a EULA to be accepted.

**Cached mode and offline mode**

‘Cached mode’ turns BatchPatch into a central distribution point that will cache Windows Updates and act as a conduit for the cached updates to be applied to target computers.

‘Offline mode’ provides a facility to easily apply Windows Updates to computers that do not have access to the internet or a WSUS server.
When ‘cached mode’ is enabled, the computer that is running BatchPatch will download all updates directly to its own local repository. Once downloaded to BatchPatch’s local repository, BatchPatch will handle distributing the updates to target computers. Target computers will not download their own updates from Microsoft, thus significantly reducing the overall amount of internet bandwidth used to retrieve Windows Updates.

When ‘cached mode’ is enabled without also enabling ‘offline mode’, target computers still require internet access because each target computer will perform its own online search for updates against Microsoft’s server. However, the actual download process will take place on the BatchPatch computer, not on the target computers, thus saving internet bandwidth since any available update will only be downloaded one time by the BatchPatch computer rather than being downloaded one time by each target computer. Once BatchPatch has downloaded updates to its cache, it is able to distribute them to target computers.

When ‘offline mode’ is enabled in conjunction with ‘cached mode’ each target computer does an offline search for available updates, utilizing the offline scan file (wsusscn2.cab) that Microsoft provides, which means that target computers do not need to have internet access. The actual update download process will only take place through the BatchPatch computer. Once BatchPatch has downloaded updates to its cache, it is able to distribute them to target computers. With ‘offline mode’ it is also possible to download updates on a BatchPatch computer that has internet access, and then manually move the entire update cache repository to a computer or network that has no internet access, enabling you to distribute Windows Updates to computers on a completely offline network.

Note: Since WSUS already provides a central distribution point for Windows Updates, running BatchPatch in ‘cached mode’ is intended only for environments that are not using a WSUS server. However, ‘cached mode’ does work with WSUS environments, despite being redundant. In this case Tools > Settings > Windows Updates > Server Selection controls where BatchPatch retrieves updates from to populate its own repository.

Please visit Cached Mode and Offline Updates for more information and tutorials on using cached mode and offline mode.

**Remote Execution**

**Remote Working Directory**

The default remote working directory is C:\Program Files\BatchPatch. This directory will be created on all remote hosts when you execute BatchPatch actions on those hosts.

**Use PsExec – r switch to specify remote service name**

This setting requires PsExec version 2 or newer. Older versions of PsExec will cause BatchPatch to produce an error for most actions if you specify a value for this setting.

This setting allows you to specify a custom remote service name. Instead of using the default remote service name (PSEXESVC) this setting allows you to provide your own custom name for the remote service.

**Remote Execution Context**

This setting determines the execution context used for remote commands and deployments.
SYSTEM (default): Run the remote process in the SYSTEM account

Elevated token: Run the remote process with the account's elevated token, if available

Normal: Run the remote process normally

Limited: Run the remote process as a limited user (strips the Administrators group and allows only privileges assigned to the Users group)

NOTE: In many cases there will be no discernible difference in the behavior of remote commands run under different execution contexts. However, in some cases commands might only run successfully under a particular context. We find that using the SYSTEM account works best for most users in most situations.

**Email Notifications Settings**

**From (email address)**

This field is required, though if you specify SMTP logon credentials, this field might be ignored by your email server.

**Recipients (comma separated or one email address per line):**

If you do not enter a properly formatted email address, BatchPatch will simply strip it from the recipients list.

**SMTP Server:**

Frequently this value would be “smtp.yourdomain.com” but of course it depends on your organization's configuration.

**Port:**

Default is 25, though your server may require a different port.

**Unauthenticated / Specify SMTP logon credentials**

In order to use the unauthenticated option, your server must be configured to allow this type of connection.

**Body format**

We recommend that you set the body format to 'plain text' and then tick the box to include an HTML attachment. Many email clients will not properly render the HTML body, but if you include an HTML attachment then you'll be able to open the attachment in a browser, which should render it properly.

**Subject**

If you want to include the host name of the row that initiated the email notification, you may use $host for that purpose.

**Body**

This field will be used as a template for your email notification body. BatchPatch supports the following keywords:

$row – BatchPatch will substitute the grid content from the row that initiated the email notification.
$host – BatchPatch will substitute the host name from the row that initiated the email notification.

$grid – BatchPatch will substitute the grid content for the entire grid that contains the row that initiated the email notification.

$allgrids – BatchPatch will substitute the grid content for all grids in the running instance of BatchPatch when an email notification is sent.

**Include HTML Attachment**

We recommend leaving this option ticked so that an HTML version of the BatchPatch grid is included with the email notification.

**Send test email**

This option allows you to test your email settings/configuration to make sure you have the correct SMTP server, port, credentials, and SSL requirement.

**Ping Status Alerts Settings**

**Global default alert settings for NEW rows:**

The 4 checkboxes in this section (Alert when host comes online, Alert when host goes offline, Audible alert, Email alert) control the default Ping Status Alert setting for new rows added to a grid.

**Alert sounds for ALL rows**

If you have enabled audible ping status alerts for a row, use this setting to choose a custom .wav file sound to be played when a host goes offline or when a host comes online. If these fields are left blank, BatchPatch will use its built-in sounds.

**Hosts are considered offline after X ping timeouts**

When you reboot a host, BatchPatch will automatically start pinging it. You can also manually ping any host using the Start Pinging action. In either case, BatchPatch uses this setting to determine how many ping **TimedOut** or **DestinationHostUnreachable** responses will trigger an offline status notification in BatchPatch. Offline status notifications are printed to the 'All Messages' column, and if you have Ping Status Alerts (see Actions > Ping status alerts) enabled, then you will receive an audible and/or email alert as well.

**Automatically stop pinging when host comes online after having been offline**

When you reboot a host, BatchPatch will automatically start pinging it. You can also manually ping any host using the Start Pinging action. In either case, BatchPatch uses this setting to determine if it should automatically stop pinging a host that has come online after having been offline. Hosts are considered offline according to the previous setting. When a host comes online after having been offline, BatchPatch will turn the ping reply text blue along with the LED image icon for that row. If this checkbox is ticked, the host will stop pinging and the row coloring will remain blue, accordingly. If this checkbox is unticked, then after the host is back online and 5 successful “blue” pings have occurred, BatchPatch will reset the blue coloring back to black and continue to the ping the host. The 'All Messages' column will still retain the datetime stamps for when the host went offline and when it came back online.
Show ping status alerts image column when adding hosts to new grid

This setting controls whether or not the 'Ping Status Alerts' image/icon column is made visible automatically by BatchPatch when you add hosts to a new/empty grid.

Run as service settings

You can use this screen to configure the settings used to run BatchPatch as a service, and to install/uninstall the service. Installation requires administrator privileges. When you install the BatchPatch service, it is configured to use the same user account that you use to run BatchPatch. After installation if you subsequently launch BatchPatch under a different account than the BatchPatch service is running, BatchPatch will be unable to communicate with the service since the service installation is tied to the user account that installed it. If there are multiple BatchPatch users on the same computer, each user is able to install an instance of the BatchPatch service to interact with his/her own logon account.

Once the service has been installed, you can use this screen to add and remove .bps files from the service instance. The service instance runs independently from the primary :"live" BatchPatch instance. Grids must be created in the “live” instance, and then they can be “sent” to the service instance. Once running in the service instance grids can be monitored/viewed using the “Launch selected .bps file(s) in viewer” option. However, grids cannot be modified in the service instance. To modify a grid, you must first remove it from the service instance.

Audit Logging Settings

BatchPatch provides you with simple audit logging to help track which actions have been executed on target hosts at which times and by whom.

When audit logging has been enabled, all messages that are written to the 'All Messages' column will also be written to the designated audit log file along with the datetime, current user, target host name, and target user.

The 'current user' is the name of the logon account that was used to launch/run batchpatch.exe. The 'target user' is the user that was specified in the 'Alternate Credentials' column for a given row to execute remote actions on the target host. If no alternate credentials were specified for a row, then the 'target user' will be written as 'Integrated Security,' in the audit log, which means the target user impersonated the current user for that action.

VIEW

Multi-grid mode

Provides an alternate way to look at grids in the window.

Toggle multi-grid layout

Choose between the following layouts:

Cascade
Tile horizontally
Tile vertically
Other

General Tips

Host Status “LED” Color Indicators

BatchPatch has the ability to check the online / offline status of all hosts listed in the grid, independently of all other actions. In any grid, you can stop or start the host status check by clicking the “LED” icon column header. When you start this check, a single thread will be created to ping each host in the grid, sequentially.

Green == Host is pingable
Yellow == Host is currently being checked
Orange == Host does not exist or cannot be found
Red == Host exists and can be found, but pings to the host are timing out
Pink/Gray == Row is excluded from host status check
Gray == No information for the row

--Middle-click on the LED column header == clear all LEDs and reset to gray
--Middle-click on the LED image for a specific row to disable that row from the host status check. The LED will turn a pink-gray color.
--Shift-MiddleClick on any row's LED == turn the LED blue to indicate completion, if you like. A blue LED will stay blue as long as the host is pingable/online.

Note, while the host status check is convenient to use at times, it is not the only way that the “LED” indicator icons will change color. In fact, if you leave the host status check disabled / off, when you ping a host or reboot a host, the LED for that host will be colored according to the same rules as are listed above.

Keyboard Shortcuts

1.  Middle-clicking a cell (scroll wheel click) will display the contents of that cell in a tooltip window. Ctrl-LeftClick or Right-click or Middle-click anywhere on the tooltip to drag it to a new location.
2.  Middle-clicking on a cell in the WSUS Installation Progress column while updates are downloading or installing will show you the name of the current update
3.  Middle-clicking on a cell in the Scheduled Task, Scheduled Time, or Task Recurrence columns will display the Task Scheduler form for that row
4.  Left-clicking the host status "LED" indicator column header will stop/start the host status check
5.  Middle-clicking the host status "LED" indicator column header will reset the entire column's "LED" images
6.  Middle-clicking a host status "LED" indicator cell will toggle that specific cell's "LED" on/off, so that individual rows can be excluded from the check
7.  Shift-middle-clicking a host status "LED" indicator cell will turn that specific cell's LED to blue, thereby indicating a status of "complete" for that row
8.  Double-clicking a row will expand the entire row to reveal all cell contents
9.  Right click anywhere on the title bar to minimize BatchPatch to the system tray
10. Toggle the grid border style with Ctrl-B
11. Click on the tiny arrow in the lower-left corner to adjust the alternating row color intensity
12. Move highlighted row(s) up or down in the grid with Ctrl-Plus and Ctrl-Minus
13. Rearrange Toolstrip buttons with ALT-LeftClick drag

**Tutorials**

Please visit the [BatchPatch Tutorials](http://www.example.com/tutorials) section of our website for numerous tutorials and helpful materials.